模板X

位置: 破奇网  帝国cms  帝国cms教程

帝国7.5支持PHP7.x版本吗

栏目: 帝国cms教程    更新: 2019-09-10    浏览:
帝国cms7.5是支持PHP7.x的,包括现在的PHP7.3,如果你的帝国cms网站在PHP5.x下能运行在PHP7.x下却显示空白,可能有以下几个问题。

1、安装帝国程序的时候“MYSQL接口类型”没有选择Mysqli,导致数据库连接方式不支持PHP7.x下的Mysqli,从而导致程序运行不了,如果程序还未安装,则在安装的时候记得选择Mysqli,如果帝国cms程序已经安装,则看第二个问题。

2、打开配置文件/e/config/config.php,找到【$ecms_config['db']['usedb']='mysql';】这行,把mysql改成mysqli即可支持PHP7.x版本。

想要帝国cms运行在PHP7.x上,程序必须是帝国cms7.5及以上,服务器PHP环境必须安装有PHP7.x版本。

附件下载 [ 下载次数:999 ]

    收藏、推荐